flatcam

Open full view…

Can't get Flatcam to work with Windows 7/AMD64

wykat
Thu, 31 May 2018 09:15:53 GMT

Spend several hours this morning in order to try to get Flatcam to work on my PC but

wykat
Thu, 31 May 2018 09:19:51 GMT

Something went wrong, so new try ;-) (it's no my day I think) First loaded WinPython 3.6 but then I couldn't install the PyQt4 module (appears no longer supported by Python 3.x The switched to WinPython 2.7 but there I can't get the module spatialindex_c.dll installed Does Flatcam only work on python 32 bit? Anyhow just following the manual didn't work for me and I haven't found a solution to install it on a (actual) windows PC. What am I missing?

wykat
Thu, 31 May 2018 10:11:47 GMT

Just loaded a nightly build, reinstalled python 3.6 (don't know if that was needed) and Flatcam works immediately :-)

Marius Stanciu
Thu, 31 May 2018 16:31:36 GMT

The Nightly builds are standalone, there is no need for Python to be installed.

wykat
Fri, 01 Jun 2018 12:16:26 GMT

great, thx, still have to go some steps, would like to 'print' my boards myself.