flatcam

Open full view…

FlatCAM not support in macOS High Sierra

wilsontan
Mon, 04 Sep 2017 09:08:05 GMT

I try to install flatcam under macOS High Sierra but the pyqt4 is not support on macOS High Sierra. install pyqt4 also a pain on macOS Sierra. seem homebrew only support pyqt5. only able to install pyqt4 through macport.

enauman
Thu, 26 Oct 2017 22:53:44 GMT

Did you find a resolution to this? I'm having the same problem.

Viktor Hedefalk
Wed, 15 Nov 2017 08:28:43 GMT

+1, the whole python thing is a mess on osx/homebrew. I ended up braking my python installation entirely it seems when trying to get pyqt4 working. Now I don't even have pip and homebrew can't seem to fix it.

enauman
Wed, 15 Nov 2017 11:03:51 GMT

I ended up using a windows machine.

nandox7
Wed, 03 Jan 2018 13:36:44 GMT

I managed to make it work forcing install of PyQT4 using: brew install cartr/qt4/pyqt (as seen in: https://robonobodojo.wordpress.com/2017/02/08/installing-pyqt4-on-mac-osx/) As well as installing some extra libs using pip that are not listed in the docs, like svg.path, but those you can pick from the errors. Finally form the cloned git folder just run ./flatcam

brainstorm
Thu, 15 Feb 2018 12:07:16 GMT

There's an ongoing effort to port it to python3 and pyqt5 over here: https://bitbucket.org/jpcgt/flatcam/pull-requests/75/initial-port-to-python3-and-pyqt5/diff Please feel free to test it out and help out. Be warned that there are bugs still, so pullrequests against that branch are welcome.

electrophile
Fri, 23 Feb 2018 07:57:36 GMT

@nandox I followed your guide but I'm not sure how I can add pyqt folder to my Python Path. How do I do that?