ikalogic

Open full view…

SQ25 recognized, but ScanaStudio says "Device ist not connected"

professor_fate
Sun, 10 Feb 2019 14:31:06 GMT

System version: Linux veteran 4.12.14-lp150.12.45-default #1 SMP Mon Jan 14 20:29:59 UTC 2019 (7a62739) x86_64 x86_64 x86_64 GNU/Linux ScanaStudio version: 3.0.20 Serial #: 1003020-DEMO (Why "demo"?&quest;) The SQ25 is recognized as a USB-to-RS232 converter: --- bash ╭─jacek@veteran ~ ╰─➤ dmesg | tail [ 7219.908020] usb 1-1.4: new full-speed USB device number 8 using ehci-pci [ 7220.025051] usb 1-1.4: New USB device found, idVendor=0403, idProduct=6015 [ 7220.025068] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3 [ 7220.025069] usb 1-1.4: Product: ScanaQuad SQ25 [ 7220.025070] usb 1-1.4: Manufacturer: IKALOGIC [ 7220.025071] usb 1-1.4: SerialNumber: 1003020001964 [ 7220.027939] ftdi_sio 1-1.4:1.0: FTDI USB Serial Device converter detected [ 7220.027965] usb 1-1.4: Detected FT-X [ 7220.028290] usb 1-1.4: FTDI USB Serial Device converter now attached to ttyUSB0 --- On the system side, the `ttyUSB0` appears to run at a baudrate of 9600. I suspect this to be the cause of my issue: --- ╭─jacek@veteran ~ ╰─➤ sudo stty -F /dev/ttyUSB0 -a [sudo] Passwort für root: speed 9600 baud; rows 0; columns 0; line = 0; intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; discard = ^O; min = 1; time = 0; -parenb -parodd -cmspar cs8 hupcl -cstopb cread clocal -crtscts -ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr icrnl ixon -ixoff -iuclc -ixany -imaxbel -iutf8 opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0 isig icanon iexten echo echoe echok -echonl -noflsh -xcase -tostop -echoprt echoctl echoke -flusho -extproc --- What's wrong here? Thank you.

Ibrahim KAMAL
Sun, 10 Feb 2019 14:33:48 GMT

Hi, You just need to run the device compatibility wizard, from ScanaStudio, in the top-right settings menu. Please let me know if this helps!

professor_fate
Sun, 10 Feb 2019 18:22:25 GMT

Works! Thank you! :D But you should really add this step to the installation guide.