ikalogic

Open full view…

ScanaStudio 3.1.0 beta F does not update/dl new protocols on Linux

nettings
Thu, 31 Jan 2019 20:35:18 GMT

Hi, I've installed the Linux tar.bz2 as instructed, it works and updates the firmware correctly. However, the protocol manager does not update or download any new protocol decoders from github. The respective buttons do nothing, and no error msgs on the console. Manual download would be fine, but where do I place the files? I specifically need a working I2S decoder.

nettings
Thu, 31 Jan 2019 20:56:17 GMT

Possible hint: when I "Check for software update" via the settings button, I get "Error code: Error creating SSL context (error:140A90C4:SSL routines:func(169):reason(196))", maybe the same error happens silently during decoder update? It appears ScanaStudio expects the openssl 1.0.0 API, whereas current distros are using 1.1. A parallel installation is alas not possible, at least on openSUSE Tumbleweed.... Any chance of rolling another beta linked against the current openssl library?

nettings
Thu, 31 Jan 2019 21:20:40 GMT

Tried some LD_LIBRARY_PATH hackery, without success. A recipe for manual downloading of the stuff from github would make me very happy...

nettings
Thu, 31 Jan 2019 21:38:18 GMT

Ah. The decoders are in ~/.local/share/Ikalogic/ScanaStudio/decoders. Manually copy them here from github, restart ScanaStudio, happy user.

nicolas_ikalogic
Tue, 05 Feb 2019 13:40:32 GMT

Hi, and thank you for using ScanaStudio. It seems that SSL Library isn't correctly packaged in the tar.bz2 file. It should be fixed with the next update. Therefore, you will should re-instal the entire package when it will be released, in the next few days.

nicolas_ikalogic
Wed, 06 Feb 2019 09:06:05 GMT

You can also find the folder of the decoders using the "Open local folder button" of the protocol manager [Open_local_directory](//muut.com/u/ikalogic/s1/:ikalogic:PQAi:open_local_directory.png.jpg)